Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel

Что возвращает функция

Возвращает логическое значение TRUE (Истина), при выполнении условий сравнения в функции и отображает FALSE (Ложь), если условия функции не совпадают.

Синтаксис

=OR(logical1, [logical2],…) – английская версия

=ИЛИ(логическое_значение1;[логическое значение2];…) – русская версия

Технические подробности

Функция ИЛИ возвращает значение ИСТИНА, если в результате вычисления хотя бы одного из ее аргументов получается значение ИСТИНА, и значение ЛОЖЬ, если в результате вычисления всех ее аргументов получается значение ЛОЖЬ.

Обычно функция ИЛИ используется для расширения возможностей других функций, выполняющих логическую проверку. Например, функция ЕСЛИ выполняет логическую проверку и возвращает одно значение, если при проверке получается значение ИСТИНА, и другое значение, если при проверке получается значение ЛОЖЬ. Использование функции ИЛИ в качестве аргумента «лог_выражение» функции ЕСЛИ позволяет проверять несколько различных условий вместо одного.

Синтаксис

ИЛИ(логическое_значение1;[логическое значение2];…)

Аргументы функции ИЛИ описаны ниже.

АргументОписание

Логическое_значение1 Обязательный аргумент. Первое проверяемое условие, вычисление которого дает значение ИСТИНА или ЛОЖЬ.
Логическое_значение2;… Необязательные аргументы. Дополнительные проверяемые условия, вычисление которых дает значение ИСТИНА или ЛОЖЬ. Условий может быть не более 255.

Примечания

  • Аргументы должны принимать логические значения (ИСТИНА или ЛОЖЬ) либо быть массивами либо ссылками, содержащими логические значения.
  • Если аргумент, который является ссылкой или массивом, содержит текст или пустые ячейки, то такие значения игнорируются.
  • Если заданный диапазон не содержит логических значений, функция ИЛИ возвращает значение ошибки #ЗНАЧ!.
  • Можно воспользоваться функцией ИЛИ в качестве формулы массива, чтобы проверить, имеется ли в нем то или иное значение. Чтобы ввести формулу массива, нажмите клавиши CTRL+SHIFT+ВВОД.

Аргументы функции

  • logical1 (логическое_значение1) – первое условие которое оценивает функция по логике TRUE или FALSE;
  • [logical2] ([логическое значение2]) – (не обязательно) это второе условие которое вы можете оценить с помощью функции по логике TRUE или FALSE.

Совместное использование с функцией ЕСЛИ()

Сама по себе функция ИЛИ() имеет ограниченное использование, т.к. она может вернуть только значения ИСТИНА или ЛОЖЬ, чаще всего ее используют вместе с функцией ЕСЛИ() : =ЕСЛИ(ИЛИ(A1>100;A2>100);»Бюджет превышен»;»В рамках бюджета»)

Т.е. если хотя бы в одной ячейке (в A1 или A2 ) содержится значение больше 100, то выводится Бюджет превышен , если в обоих ячейках значения <=100, то В рамках бюджета .

Сравнение с функцией И()

Функция И() также может вернуть только значения ИСТИНА или ЛОЖЬ, но, в отличие от ИЛИ() , она возвращает ИСТИНА, только если все ее условия истинны. Чтобы сравнить эти функции составим, так называемую таблицу истинности для И() и ИЛИ() .

Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel

Эквивалентность функции ИЛИ() операции сложения +

В математических вычислениях EXCEL интерпретирует значение ЛОЖЬ как 0, а ИСТИНА как 1. В этом легко убедиться записав формулы =ИСТИНА+0 и =ЛОЖЬ+0

Следствием этого является возможность альтернативной записи формулы =ИЛИ(A1>100;A2>100) в виде =(A1>100)+(A2>100) Значение второй формулы будет =0 (ЛОЖЬ), только если оба аргумента ложны, т.е. равны 0. Только сложение 2-х нулей даст 0 (ЛОЖЬ), что совпадает с определением функции ИЛИ() .

Эквивалентность функции ИЛИ() операции сложения + часто используется в формулах с Условием ИЛИ, например, для того чтобы сложить только те значения, которые равны 5 ИЛИ равны 10: =СУММПРОИЗВ((A1:A10=5)+(A1:A10=10)*(A1:A10))

Проверка множества однотипных условий

Предположим, что необходимо сравнить некое контрольное значение (в ячейке B6 ) с тестовыми значениями из диапазона A6:A9 . Если контрольное значение совпадает хотя бы с одним из тестовых, то формула должна вернуть ИСТИНА. Можно, конечно записать формулу =ИЛИ(A6=B6;A7=B6;A8=B6;A9=B6) но существует более компактная формула, правда которую нужно ввести как формулу массива (см. файл примера ): =ИЛИ(B6=A6:A9) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel

Вместо диапазона с тестовыми значениями можно также использовать константу массива : =ИЛИ(A18:A21>{1:2:3:4})

В случае, если требуется организовать попарное сравнение списков , то можно записать следующую формулу: =ИЛИ(A18:A21>=B18:B21)

Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel

Если хотя бы одно значение из Списка 1 больше или равно (>=) соответствующего значения из Списка 2, то формула вернет ИСТИНА.

Примеры использования функций И ИЛИ в логических выражениях Excel

Пример 1. В учебном заведении для принятия решения о выплате студенту стипендии используют два критерия:

  1. Средний балл должен быть выше 4,0.
  2. Минимальная оценка за профильный предмет – 4 балла.

Определить студентов, которым будет начислена стипендия.

Для решения используем следующую формулу:

=И(E2>=4;СРЗНАЧ(B2:E2)>=4)

Описание аргументов:

  • E2>=4 – проверка условия «является ли оценка за профильный предмет не менее 4 баллов?»;
  • СРЗНАЧ(B2:E2)>=4 – проверка условия «является ли среднее арифметическое равным или более 4?».

Как видно выше на рисунке студенты под номером: 2, 5, 7 и 8 — не получат стипендию.

Формула с логическим выражением для поиска истинного значения

Пример 2. На предприятии начисляют премии тем работникам, которые проработали свыше 160 часов за 4 рабочих недели (задерживались на работе сверх нормы) или выходили на работу в выходные дни. Определить работников, которые будут премированы.

Исходные данные:

Формула для расчета:

=ИЛИ(B3>160;C3=ИСТИНА())

Описание аргументов:

  • B3>160 – условие проверки количества отработанных часов;
  • C3=ИСТИНА() – условие проверки наличия часов работы в выходные дни.

Используя аналогичную формулу проведем вычисления для всех работников. Полученный результат:

То есть, оба условия возвращают значения ЛОЖЬ только в 4 случаях.

Формула с использованием логических функций ИЛИ И ЕСЛИ

Пример 3. В интернет-магазине выполнена сортировка ПК по категориям «игровой» и «офисный». Чтобы компьютер попал в категорию «игровой», он должен соответствовать следующим критериям:

  1. CPU с 4 ядрами или таковой частотой не менее 3,7 ГГц;
  2. ОЗУ – не менее 16 Гб
  3. Видеоадаптер 512-бит или с объемом памяти не менее 2 Гб

Распределить имеющиеся ПК по категориям.

Описание аргументов:

И(ИЛИ(B3>=4;C3>=3,7);D3>=16;ИЛИ(E3>=2;F3>=512)) – функция И, проверяющая 3 условия:

  1. Если число ядер CPU больше или равно 4 или тактовая частота больше или равна 3,7, результат вычисления ИЛИ(B3>=4;C3>=3,7) будет значение истинное значение;
  2. Если объем ОЗУ больше или равен 16, результат вычисления D3>=16 – ИСТИНА;
  3. Если объем памяти видеоадаптера больше или равен 2 или его разрядность больше или равна 512 – ИСТИНА.

«Игровой» — значение, если функция И возвращает истинное значение;

«Офисный» — значение, если результат вычислений И – ЛОЖЬ.

Этапы вычислений для ПК1:

  1. =ЕСЛИ(И(ИЛИ(ИСТИНА;ИСТИНА);ЛОЖЬ;ИЛИ(ЛОЖЬ;ЛОЖЬ));»Игровой»;»Офисный»)
  2. =ЕСЛИ(И(ИСТИНА;ЛОЖЬ;ЛОЖЬ);»Игровой»;»Офисный»)
  3. =ЕСЛИ(ЛОЖЬ;»Игровой»;»Офисный»)
  4. Возвращаемое значение – «Офисный»

Особенности использования функций И, ИЛИ в Excel

Функция И имеет следующую синтаксическую запись:

=И(логическое_значение1;[логическое_значение2];…)

Функция ИЛИ имеет следующую синтаксическую запись:

=ИЛИ(логическое_значение1;[логическое_значение2];…)

Описание аргументов обеих функций:

  • логическое_значение1 – обязательный аргумент, характеризующий первое проверяемое логическое условие;
  • [логическое_значение2] – необязательный второй аргумент, характеризующий второе (и последующие) условие проверки.

Примечания 1:

  1. Аргументами должны являться выражения, результатами вычислениями которых являются логические значения.
  2. Результатом вычислений функций И/ИЛИ является код ошибки #ЗНАЧ!, если в качестве аргументов были переданы выражения, не возвращающие в результате вычислений числовые значения 1, 0, а также логические ИСТИНА, ЛОЖЬ.

Примечания 2:

  1. Функция И чаще всего используется для расширения возможностей других логических функций (например, ЕСЛИ). В данном случае функция И позволяет выполнять проверку сразу нескольких условий.
  2. Функция И может быть использована в качестве формулы массива. Для проверки вектора данных на единственное условие необходимо выбрать требуемое количество пустых ячеек, ввести функцию И, в качестве аргумента передать диапазон ячеек и указать условие проверки (например, =И(A1:A10>=0)) и использовать комбинацию Ctrl+Shift+Enter. Также может быть организовано попарное сравнение (например, =И(A1:A10>B1:B10)).
  3. Как известно, логическое ИСТИНА соответствует числовому значению 1, а ЛОЖЬ – 0. Исходя из этих свойств выражения =(5>2)*(2>7) и =И(5>2;2>7) эквивалентны (Excel автоматически выполняет преобразование логических значений к числовому виду данных). Например, рассмотрим этапы вычислений при использовании данного выражения в записи =ЕСЛИ((5>2)*(2>7);”true”;”false”):
  • =ЕСЛИ((ИСТИНА)*(ЛОЖЬ);”true”;”false”);
  • =ЕСЛИ(1*0;”true”;”false”);
  • =ЕСЛИ(0;”true”;”false”);
  • =ЕСЛИ(ЛОЖЬ;”true”;”false”);
  • Возвращен результат ”false”.

Примечания 3:

  1. Функция ИЛИ чаще всего используется для расширения возможностей других функций.
  2. В отличие от функции И, функция или эквивалентна операции сложения. Например, записи =ИЛИ(10=2;5>0) и =(10=2)+(5>0) вернут значение ИСТИНА и 1 соответственно, при этом значение 1 может быть интерпретировано как логическое ИСТИНА.
  3. Подобно функции И, функция ИЛИ может быть использована как формула массива для множественной проверки условий.

Подстановочные знаки в Excel.

​ B2, поэтому формула​​ ко внешнему оператору​ функция возвращает значение​​(обязательно)​ к ней ещё​ а затем —​ помогла ли она​​ такую формулу. =СЧЁТЕСЛИ(A1:A10;B2)​​ в пустой ячейке​​ в ячейке A4,​Показать формулы​ и A3 не​
​ A1 и нажмите​ Таким образом, наша задача​, нужно сразу набрать​ будут добавлены знак​ возвращает значение ЛОЖЬ.​ ЕСЛИ. Кроме того,​ ИСТИНА.​Условие, которое нужно проверить.​
​ можно как нибудь​ клавишу ВВОД. При​ вам, с помощью​О других способах применения​ пишем такую формулу.​ возвращается «ОК», в​
Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel
​.​ равняется 24 (ЛОЖЬ).​ клавиши CTRL+V.​Во многих задачах требуется​ полностью выполнена.​ на клавиатуре знак​ равенства и кавычки:​Вы также можете использовать​ вы можете использовать​=ЕСЛИ(И(A3=»красный»;B3=»зеленый»);ИСТИНА;ЛОЖЬ)​
​значение_если_истина​​ добавить типо… Если​​ необходимости измените ширину​​ кнопок внизу страницы.​​ подстановочных знаков читайте​ Мы написали формулу​ противном случае —​Скопировав пример на пустой​=НЕ(A5=»Винты»)​
​Важно:​ проверить истинность условия​Знак​«меньше»​=»ИЛИ(A4>B2;A4. Вам потребуется удалить​ операторы И, ИЛИ​
Символ
​ текстовые или числовые​Если A3 («синий») =​(обязательно)​ A1=1 ТО A3=1​ столбцов, чтобы видеть​ Для удобства также​Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel
​ в статье «Примеры​ в ячейке В5.​​ «Неверно» (Неверно).​​ лист, его можно​​Определяет, выполняется ли следующее​​ Чтобы пример заработал должным​​ или выполнить логическое​«≠»​(, а потом элемент​ кавычки, чтобы формула​ и НЕ в​ значения вместо значений​ «красный» и B3​Значение, которое должно возвращаться,​ Ну вообщем вот​ все данные.​ приводим ссылку на​ функции «СУММЕСЛИМН» в​
Символ
​=СЧЁТЕСЛИ(A1:A10;»молок*») Как написать​=ЕСЛИ(И(A2<>A3; A2<>A4); «ОК»; «Неверно»)​ настроить в соответствии​ условие: значение в​ образом, его необходимо​Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel
​ сравнение выражений. Для​используется исключительно в​«больше»​ работала.​ формулах условного форматирования.​
​ ИСТИНА и ЛОЖЬ,​ («зеленый») равно «зеленый»,​ если лог_выражение имеет​​ это ЕСЛИ(И(A1=5;А2=5);1 и​
​Формула​ оригинал (на английском​ Excel».​ формулу с функцией​Если значение в ячейке​ с конкретными требованиями.​ ячейке A5 не​
Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel
​ вставить в ячейку​​ создания условных формул​
​ визуальных целях. Для​(>)​К началу страницы​ При этом вы​ которые возвращаются в​ возвращается значение ИСТИНА,​ значение ИСТИНА.​ вот это Если​Описание​ языке) .​Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel
​Как найти все слова​
Функция OR (ИЛИ) в Excel: как использовать? Функции ИЛИ в Excel
​ «СЧЕТЕСЛИ», читайте в​ A2 равно значению​1​
​ равняется строке «Винты»​ A1 листа.​ можно использовать функции​ формул и других​. В итоге получается​
​Если такие знаки сравнения,​ можете опустить функцию​ примерах.​ в противном случае​значение_если_ложь​
​ A1=1 ТО A3=1 ​

Источники
  • https://excelhack.ru/funkciya-or-ili-v-excel/
  • https://support.microsoft.com/ru-ru/office/%D0%B8%D0%BB%D0%B8-%D1%84%D1%83%D0%BD%D0%BA%D1%86%D0%B8%D1%8F-%D0%B8%D0%BB%D0%B8-7d17ad14-8700-4281-b308-00b131e22af0
  • https://excel2.ru/articles/funkciya-ili-v-ms-excel-ili
  • https://exceltable.com/funkcii-excel/primery-logicheskih-funkciy-i-ili
  • https://my-excel.ru/excel/v-excel-znak-ili.html

Как прописать функцию "если" с несколькими условиями в программе Excel? Функция ЕСЛИ в Excel. Примеры (с несколькими условиями)
Сводные таблицы в Excel с примерами и описанием. Сводные таблицы в Excel специально для чайников

ITandLife.ru
Adblock
detector